Modèle:Plateforme de développement

De OSWiki
Sauter à la navigation Sauter à la recherche

.NET Framework

.Net Framework 4.0, open source depuis 2015, est utilisé par Windows pour exécuter OpenSimulator. Vérifiez la version de votre système.

Plus d'informations sur .NET Framework.

.Net peut également être installé sous Linux et MacOS. Pour plus d'informations visitez cette page : https://www.microsoft.com/net/core

Mono

Mono est une mise en œuvre open source de la plateforme de développement Microsoft .NET

Mono est utilisé pour lancer OpenSimulator sous GNU/Linux et MacOS mais peut aussi être utilisé sous Windows.

Il est recommandé d'utiliser une version Mono 2.10.8 ou supérieure. Mais toutes les versions de Mono ne sont pas adaptées à OpenSimulator. Si la version de votre système d'exploitation ne permet pas de lancer Mono, ou provoque de gros bogues, il faudra la remplacer.